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1. Introduction

Tanner Tools & Analog, Mixed-Signal 22|11 MEMS IC Design & Zl&st=0 Z Q% Schematic
Capture, Analog Simulation, Physical Layout, Verification, Synthesis 0f Place & Route 7| &7tX| 2

S Design Flow 0f sjE8t HES ereisis x|QetL|ct

0] M Tanner L-EDIT O A MEMS Layout £ ldll MSste HAH 7|s2 2t g7 st 2

M gLC.

1.1 Installation

HMEs

—

AXl 3t 20| L-EDIT € XS AdZ2 SlAHLL MNE HF2 HELP > Setup Examples and
L7

=)
Tutorial £ MEHS rograms > TannerEDA > Tanner Tools v2016.1 >

—

| Pr
Setup Examples and Tutorial & MEH S} Of2f|Qt Z0| Example 1t Tutorial Data AX| 2}HO|

LHEFEr LT

' h!
Tanner Tools Examples &l
Would you like to setup Tanner Tools examples? Setup

Examples will be by default installed in a subfolder of your My Documents folder. Later
You will be allowed to change this location during setup. e

If you choose to do this setup later, you can also invoke it from the Help menu
of L-Edit, LVS, T-Spice. or S-Edit, or from the Windows Start menu.

I~ Dont show this dialog again on start up

2 o 3tHOAM Setup = MEHSIH, LHEA| > TannerEDA> Tanner Tools v2016.1 > Tutorial C|

HEZ|0f CIOJE7F 250 HLICH e, oiE Tutorial CIXtQIO] ~FE|ALL HE MH7F & BF

flel a8 S AMER| CHAl Data & EXE & UASLICH




2. MEMS Layout

Ol MMO|A= MEMS Layout Design 2 L-EDIT £ 0|83l HESI=0O JA0N 83 7|5

2 7HXE MSELLh

2.1 Boolean / Grow Operation

MZ& Polygon 2 2t= [, Draw > Boolean / Grow Operation & O|&%}0] 0|0 Tt=0{ %l &}

EI_E

Lt O] &2 tHE Object of Logical A4ts Tl & & USLCH

Boclean/Grow Operations

Besut JIEIE 2 i
Operation: | Grow ~| Br |5.I}DD illMicmns Cancel

Inputs: 1 box on Active

[ Delete inputs after operation is done

Logical A4tE TIAe StLf O[42| Object & & St 20 L-EDIT 2 T O w0jAf Draw >

Boolean / Grow Operation & S5jA TI& & 4= Q&L|Ct All-Angle Polygon, Wire, Circle, Pie
Wedge, Tori 7t % Qo Object @ MEHE & UAL|CH sl Object 2 MEHS}T, XIS
X} Sl Operation 1 Result £ MEESID OK HHEZS ZS2I6tH, offE Z4t Layer 7t L-EDIT &

of 20jX[A ELICt

Exercise 1 - Adding/Subtracting Layers

Step 1. Open £ Q= 2E Cell Layout Window £ Close tL|LC}.

AN

=

Step 2. File > Open 2 MEHSIO|, Tutorial Data C|EH EZ|0| QU= Tutorial.tdb IS MEHSIO

Open gfL|C}.




Step 3. Design Navigator 0| A| Exercise_5 Cell MEHSL0| Open gfL|Ct.

Step 4. Exercise_5 Cell Layout 2| Metal3 box £ MEHSIO] Of2jQt ZH0| @H# == SXIQIL|C}t

»
Step 5. ity ruB AE|Z (9| Ploy & MEHS E Metal3 & MEHSHL|CE

o = = 71 = (S ]

Step 6. Draw > Boolean / Grow Operation £ MEHS|HL} HOTKEY B € 0|235lQ] Ofzfo| &2

o

= gt

—

-

Boolean/Grow Operations &Jw
Besult: [N Well] ﬂ J QK |

Operaton: [ETE-] & fo0 = Cancel
Inputs: : 1 box on Metal3
B: 1 box on Poly

I Delete inputs after operation is done

Step 7. 29| Ot Z0| Result = N-Well Layer & MEHSGID Operation 2 Subtract (B-A) £

Meietn oK £ 2zrct

A 2t B o Ciet 2= /o 2 Inputs EE Sof A @ B 0f siFdt= Objects FEE =
olgt = ULt

Step 8. J2|™H Of2fjet Z2 Logical A ZANIL N-Well Layer HEfZ EOf Tl L|C}.




Step 10. O|H| X2 TS E Layout Window £ Close $tL|LC}.

=

/ End of Exercise

2.2 Mask Bias

OF

Mask Bias 7|5< O|83}0], Ct2 Geometrics Objects Layer ZHO]| AtM| &AL} Resize 2 &

= = T

UZELICEH SHE 7|52 Tools > Add-Ins > Mask Bias 0|52 Es|A & £ JYHLICH

rMask Bias ﬁﬁ
R X4

- Cancel
Drawn Grow By (Microns) Mask

[ Delete geometry on target layer prior to resize
[ Delete geometry on source layer after resize
[ Merge geometry after resize

Resize geometry in:
+ Active cell only
(" Selected objects in active cell only
(™ Active cell and descendants

Al cells in active file

Drawn -= Mask ‘ Mask -> Drawn ‘

et Layer Of Microns Number & 7|23510], siY Layer & =&SIAHLE HAG = UGSLICH £
ot MEHSE Layer O Geometry Data & =35I LI A =2 Merge HA| Tl gt = Q&LICH
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2.3 Curves

L-EDIT Of|A H|&38t= all-angle Tool & 0|873}0{, Polygon 9| edge & Orthogonal, 45-degree,
=2 all-angle HE{O| Curve 2 BHAY = USZL|CE O FH2 7[E0| THS0{TI Polygon Of Tt
A =

HEO| =1, oY Curve & MEFH YG3HA|

Step 1. 2M3}g|0] Y= B E Cell Layout Window £ Close gtL|C}.

Step 2. Cell Exercise_5 & Open gfL|LC}.

;
»

=

Step 3. Exercise_5 2| Layout &0 Blue Polygon 2| 3t Edge £ @I key, use the RMB

£ 0| 83}0] MEfgtL|Ct

GRS

!
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i E
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EEEGEGETC]
smaom Fmo

@' key, =
=

2D e HEfO|M OtRAQl & HE 2250] OffA HMZ ARC 2 HZEDH
20| E2i1a st siT Edge & Curve Edge 2 B AT = QUL L|CH

sty U UKV B 52D s MEOA OIA B HES 2SS OpeA o of
. L7 ARC 2 #Z0| E|X| Y= Z29 Step > Application - General B %9

~lD Drawing mode £ All Angle & Curves 2 HZASH S0 CtA| A|E3| 2HH EL|C}

Step 4. O|A| Exercise_5 Cell € Close BtL|LC}.

/ End of Exercise
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2.3.1 Chamfers & Fillets

T 7HQ| Surface & AASt= Chamfer & User & ASHA|= Style 2 Foid &= UHL|CH Lt
45-degree HEZ AZAO| &|X|2F Fillet & 0|23} Of2ft &0| Curved HE|ZE Chamfer

.|
S|
£ Fog = = AL

Chamfered edges Filleted edges

0|t &2 =eE TIASI7| QoA = L-EDIT AEtO| Draw > CurveTools > Chamfers... 0| 7Lt

Draw > CurveTools > Fillet... =& MEHS|A OF2j2] Chamfer/Fillet =S S8 At %= QU

S LIC

r ™
Chamfer/Fillet 5

—Operation ~On

% Chamfer " Selected vertices ddd I Remove |

" Fillet (% Entire object
~Which vertices

[V Convex vertices Distance |24000 Microns

[V Concave vettices  Distance |2.000 Microns
~ Edages -

[ Consider multiple edges as a single edge

hich de e less that 0.025 Micron

— Limit

™ Only consider vertices whose angle is

between |30 and |1 00 degrees

[V Display markers at vertices that cant be chamfered orfilleted
[~ Create log file
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3. Exporting and Importing Data Files

S XM+& GDSI, CIF, DFX, Gerber File It BMP, GIF, JPEG, TIFF 22 I 9A| L-EDIT £ AtE3HE
gofM Import 3t0 AMEE 2= UFLCE O nHd0|M= Data £ siE M= Export /

Import 3t&= 180 CHa Tl E LTt

3.1 Exporting GDSII Files

of2fjet Z0| File > Export Mask Data > GDSII 0| =& &3df L-EDIT Design Data & GDSII ntQ

2 NEE = AL B HOo)UE Cell 2 MEY = & LICH
Export GDSIL 5
To file: GDSI units:
|Tutu:uria|.gds| Browse. . "~ GDSIl defautt (1 database unit = 0.001 microns)
™ Zip output file {* Custom: ] database unit = |0.001 microns
Export scope: 1 database unit = |0.001 user units
* Al cells Cell names:
™ Active cel * Preservecase | Uppercase " Lower case

(" Fabrication cell Restrict cell names to: |32 (Standard) w | characters

" Cell: |Hing"«-"CO_CDmp|eted:Tutorial J
" Cells from libraries: | J Map filg:
" Cells selected in navigator | Browse...
-
- | J [+ Do not export hidden objects and layers
Log fle: [+ Cwenwrite object data type with layer data type

[ Calculate MOSIS checksum
[~ Check for seffntersecting polygons and wires

[~ Fracture polygons with more than 59 vertices

I Save log file to:

¥ Open log in window

Export Cancel |

GDSI THY2 IC Design ©| AFQIEZ MUQILICH GDSI THAS MESI= ™A Zip 2 Gz
o2 ot=S BZLL X UYL Cell O] OfL|2F EX Cell S M2 XML ZE Cell of
CHSHME =2 Hierarchy X2 E£0 e AR, ST Hierarchy XE ZE3st= HER

GDSII El’%% I17C(>|-‘g- ES o|AL_||:|_

3.2 Importing GDSII Files

8
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File > Import Mask Data > GDSII £ E3f| GDSII IS A0S 5= USL|CH
( import GDSI =)

From file:
|| _v_l Browse... aea

if unknown layers are found: -

* Prompt
" Generate new layers

[V Treat different GDSII data types on a layer as different layers

QOverwrite existing cells:
Al
" Top design only
¢ None

Database resolution:

' From GDSIIfile: | microns
" Custom: I microns

~

Ql

o}
=

GDS ItE Import St= tHO|A Export & MA™SE Zip, Gz 22 =3t Q!

to

=5

rir
_E_I
mlo

=
=
| X8 =+

=
=xog Q=2 G|N St GDS e £2| SL|Ch ESH 7|& Data 0 Overwrite
Z All Overwrite £ Zlsist

0
oY o
Rl

X
Q& L|Ct &0, Display Resolution ¥A| SX7} 2dl= HEfZ BHASKA 28 2 £+ USLICH

3.3 Exporting DXF Files

Ot} Z 0| File > Export Mask Data > DXF O =Z Edl| L-EDIT Design Data & DXF It Z X
et = USLCHE DXF = A AH8StD e Cell 0 A= ZE Layer Of CHSHA XMZEZ SHA|TL
SA4AMN UAe Layer = MEES SFX| Y&LCH

.

Export DXF

BExporting cell: RingVCO_Completed
DXF dimensions: 51.875x 37.5 (Microns) Cancel

0Nl

Tofile:

Browse... Edit...

[v Export L-Edit wires as DXF open polyiines
[ Export curved objects as straight polygons

[ Flatten output




oF DALt 22

L EELER
HAl2 AutoCAD OfM AL 7Hs 3

DXF (Drawing Exchange Format) I} ¥ Al
Export L-EDIT wires as DXF open Polylines SM& XH3AZ ¢1 HES StH, ZE wire =

“Open Polylines” @E 2 M E L|CH

C{£20{, Curved Object £ straight polygons HENZ2 X ZE&t DX} Of= ZL0|= Export curved
objects as straight polygons X35l TIglistH EL|CH OEX| &S M™M, Curved Objects = Real
8t= Z <9, Data 7} Flatten StAH X

—

Curved Objects 2 X ZHE L|CL. Flatten output 2 X3 E

YELLh

3.3 Importing DXF Files

S5 A DXF mtYE L-EDIT 2 S22

o 4

ot} Z0| File > Import Mask Data > DXF 0| 7 &

|2 L-EDIT 2 2212+ 10X DXF ARC = zero-area polygon

AgHcLhL 22|20 3

ot
OIAlZ| 1 DXF LINE 2 zero-width Polyline @2 ©QIAIEIL|CE BHRF Curve HE[C| Open

290
POLYLINE O] /U= ZAL0= curved edge 2f wire 0f 256 2 ZX1tslX| U= segment 3f2 =T

sfioF gLt

=

From file:
QK
Browse ... | Edit... ﬁ

MEE Unlknown

Scale: |1 1 D¥F unit = how marny Microns?

-Objects with Mon-Zero Elevation

g

Impaort DXF

(" lgnore these objects
{* Collapse these ohjects to Z=0 plane

" Accept only objects in Z range:

Merge Open Poldines -
¥ Merge with tolerance: 0 Microns

[~ Do not import hatch fils or dimensions

|3: to |3: DI¥F units

[ Do notimport visible attibutes as ports

-

t2oil= 3D ol

I’—'I

DXF IS == Y0 SHH2 Scale Zt2 X|HY = USLICL DXF
EtE Z3E|0 Q= A27F =0, BHef 3D Object £ FA|SAXt St= A Collapse these
ot Hed HCHH,

rIJ-III

objects to Z=0 plane & MEHSIH ElL|CL Ttk EH Z ZtO| Objects Gt

10




Accept only objects in Z range S M2 MEASID RSl= 4f2 SO{FH ST Zto| Objects Bt &

= &L
sl 242 SolidWorks 9 Z+2 3D Cad Tool OfA B2 =&0| EL|CL

OrX|2k S M2 Merge Open Polyline M2 Open Polyline & sl SM0|0H, H
Of IHIHZ Object 22|&|0 AO{X|= segment 2 polygon CF HTIS|A| HAXt

ELISS

Exercise 3 - Exporting/Importing a GDSII file into L-Edit

Step 1. L-EDIT £ A&3SIY tutorial.tdb It =2{=L|Ct

Step 2. File > Export Mask Data > GDSII £ MEHTIL|LC}.

Export GDSII 5

Tofile: GDSII units:
gas Browse... " GDSI default (1 database unit = 0.001 microns)

[ Zip output file {* Custom: 1database unit = |0.001 microns
o 1 database unit = |0.001 user units

& Al cells Cell names:

" Active cel * Preservecase ( Uppercase " Lower case

(" Fabrication cel Restrict cell names to: |32 (Standard) ~ | characters

" Cell: |r'-Jr--1C'S_1:Tutc-rial

" Cells from libraries: | Map file:

(" Cells selected in navigatar | Browse...
v

- | [+ Do not export hidden objects and layers
Log file: [v Cwerwrite object data type with layer data type
 Saveloafiet [ Calculate MOSIS checksum

ave log file to:
g [ Check for seffintersecting polygons and wires
[~ Fracture polygons with more than 99 vertices
¥ Open log in window
BExport Cancel ‘
. A

flel 2gat Zo| MEE Sta Export & EEELICL

Step 3. Export & ZE|S S} H, L-EDIT 0| A Of2{e} Z2 Log & HOjF= FO| et £|0X| 2,
sf =

=
HHE Cell O] Export E[O{QUE=X] =l g 4= AL Ch
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E) Expbd6E.log E=8[E=R
GD5II Export| -
L-Edit Version: L-Edit Winé4 16.03.20130808.06:16:22
Source Design: C:\Users‘mmontalvo\Documents\Tanner EDA\Tanner Tools
Target GDSII File: C:\Users‘mmontalvo\Documentsh\Tanner EDA\Tanner Tc

Export Scope: All cells
57 cells are being exported.
Exclude hierarchy cells from libraries: COFF

GDSII units:
Custom GDSII units:
1 database unit = 0.001 microns,
1 database unit = 0.001 user units.

Cell names:
Pre=zerve case of cell names,
Restrict cell names to 32 characters.

U=ze layer map file: OFF

Optional Settings:
Do not export hidden objects and layers: CN
Overwrite object data type with layer data type: CN
Calculate MOS5IS5 checksum: OFF
Check for self-intersecting polygons and wires: CFF
Fracture polygons: OFF
Export instance names as property: Use attribute &

4 T 2

Step 4. Log |I=2E Close gfL|C}.

Step 5. O|A|, Export &t GDSII mt&-E Import 5}7| |3} File > Import Mask Data > GDSII £ M

EH 'o;F |_| |:|—.

=

Import GDSII et S|

er EDA\Tanner Tools v16.0Tutodals’ Tutorial gdsiiig Browse. .. Cancel

F unknown layers are found:
{* Prompt
" Generate new layers

Iv Treat different GDSI| data types on a layer as different layers
Overwrite existing cells:
Al
" Top design only
+ None

Database resolution:

" From GDSII file: microns

" Custom: microns

W

Step 3 O M XZTot GDSI s MEstD, fef 20| gME XE LfE Import HES 28

12
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ot of2fet Z0| Log &5 &3l Import 2HFOAM 2 LHES =2 & + UFLICH

E Impg83.log == E=RF==

EDSII Imporr... -
GDSIT File: C:‘\Users\mmontalwvo\Documents\Tanner EDA‘\Tanner Tools w

Cption Settings:
Ireat unigue GD5 data types on a layer as different layers: CHN
Using original GDS5II database resolution: 0.001 microns

m

Cell 'Via M3M4 Autol' will not be overwritten.

Cell 'Cnt_Active_RAuto4' will not be overwritten.

Cell ' Cnt Library' will not be overwritten.

Cell ' PDK Via34' will not be overwritten.

Cell ' PDK C5' will not be overwritten.

Cell ' PDK Cnt' will not be overwritten.

Cell 'Capacitor MiM' will not be overwritten.

Cell 'Capacitor_MiM Code' will not be overwritten.

Cell 'Cnt_Active' will not be overwritten.

Cell 'Cnt Active Autol' will not be overwritten.

Cell 'Cnt_ Active Auto2' will not be overwritten.

Cell 'Cnt_ Active Auto3' will not be overwritten.

Cell 'Cnt_NTAP' will not be overwritten.

Cell 'Cnt_Poly' will not be overwritten.

Cell 'Cnt_PTAP' will not be overwritten.

Cell 'CurrentMirror NMOS525' will not be overwritten.

Cell 'CurrentMirror PMOS525' will not be overwritten.

Cell 'DiffPair NMOS525' will not be overwritten.

Cell 'DiffPair PMOS25' will not be overwritten.

Cell 'HD NMOS25' will not be overwritten.

Cell 'HD PMOS25' will not be overwritten. -
] [TI] 3

Step 7. 29| Log & Edf| oigst Cell O] E2{2tX|L Overwrite £ JU=X| =0l0| 7tsTtL| T

Ol 8iE Log A& Close 8t L-EDIT & Z&¢L|CE

Step 8. ZE3l= IPHO|A tutorial.tdb = K ESHR| UL L|CH

/ End of Exercise
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